summaryrefslogtreecommitdiff
path: root/bindgen/rust/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'bindgen/rust/Cargo.toml')
-rw-r--r--bindgen/rust/Cargo.toml15
1 files changed, 5 insertions, 10 deletions
diff --git a/bindgen/rust/Cargo.toml b/bindgen/rust/Cargo.toml
index f09c249..765c5d0 100644
--- a/bindgen/rust/Cargo.toml
+++ b/bindgen/rust/Cargo.toml
@@ -1,16 +1,11 @@
[package]
-name = "celeritas"
+name = "celeritas-rs"
version = "0.1.0"
edition = "2021"
[dependencies]
-egui = "0.27.1"
-egui_glfw = "0.55.1"
-gl = "0.14.0"
-# egui_overlay = {version = "0.8.1", default-features = false, features = ["three_d"] }
-# egui_render_three_d = "0.8.0"
-# egui_render_wgpu = "0.8.0"
-# egui_window_glfw_passthrough = "0.8.1"
+celeritas-sys = { path = "./celeritas-sys" }
-[build-dependencies]
-bindgen = "0.69.4"
+egui = "0.27.1"
+egui_glfw = { git = "https://github.com/omnisci3nce/egui_glfw.git", rev = "67b432695433feb59761f3ae984b966ca3da31db" }
+gl = "0.14.0" \ No newline at end of file