summaryrefslogtreecommitdiff
path: root/deps/Unity/examples/example_1/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'deps/Unity/examples/example_1/meson.build')
-rw-r--r--deps/Unity/examples/example_1/meson.build48
1 files changed, 48 insertions, 0 deletions
diff --git a/deps/Unity/examples/example_1/meson.build b/deps/Unity/examples/example_1/meson.build
new file mode 100644
index 0000000..645eeb9
--- /dev/null
+++ b/deps/Unity/examples/example_1/meson.build
@@ -0,0 +1,48 @@
+project('Unity example', 'c',
+ license: 'MIT',
+ default_options: [
+ 'c_std=c99',
+ 'warning_level=3',
+ ],
+ meson_version: '>= 0.49.0'
+)
+
+unity_subproject = subproject('unity')
+unity_dependency = unity_subproject.get_variable('unity_dep')
+unity_gen_runner = unity_subproject.get_variable('gen_test_runner')
+
+src1 = files([
+ 'src' / 'ProductionCode.c',
+ 'test' / 'TestProductionCode.c',
+])
+
+src2 = files([
+ 'src' / 'ProductionCode2.c',
+ 'test' / 'TestProductionCode2.c',
+])
+
+inc = include_directories('src')
+
+test1 = executable('test1',
+ sources: [
+ src1,
+ unity_gen_runner.process('test' / 'TestProductionCode.c')
+ ],
+ include_directories: [ inc ],
+ dependencies: [ unity_dependency ],
+)
+
+test('test1', test1,
+ should_fail: true)
+
+test2 = executable('test2',
+ sources: [
+ src2,
+ unity_gen_runner.process('test' / 'TestProductionCode2.c')
+ ],
+ include_directories: [ inc ],
+ dependencies: [ unity_dependency ],
+)
+
+test('test2', test2)
+